<!DOCTYPE html>
<html lang="en" dir="ltr" prefix="content: http://purl.org/rss/1.0/modules/content/  dc: http://purl.org/dc/terms/  foaf: http://xmlns.com/foaf/0.1/  og: http://ogp.me/ns#  rdfs: http://www.w3.org/2000/01/rdf-schema#  schema: http://schema.org/  sioc: http://rdfs.org/sioc/ns#  sioct: http://rdfs.org/sioc/types#  skos: http://www.w3.org/2004/02/skos/core#  xsd: http://www.w3.org/2001/XMLSchema# ">
  <head> 
    <meta charset="utf-8" />
<link rel="canonical" href="https://www.algona.com/news/vietnam-vets-honored-june-25-ceremony" />
<meta name="description" content=" 

SWEA CITY—The Anna Maria Lane and Algona Chapters of the National Society of the Daughters of the American Revolution have announced the keynote speaker will be Lt. Col Tres Smith at the upcoming Vietnam Veterans Day Commemoration event to be held at the Swea City Fun Days on Saturday, June 25 at 1 p.m. at the city park." />
<meta property="og:site_name" content="Kossuth County Advance" />
<meta property="og:image" content="https://www.algona.com" />
<meta name="Generator" content="Drupal 9 (https://www.drupal.org); Commerce 2" />
<meta name="MobileOptimized" content="width" />
<meta name="HandheldFriendly" content="true" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<link rel="icon" href="/sites/default/files/Screen%20Shot%202021-09-01%20at%202.46.29%20PM_0.png" type="image/png" />

    
    <title>Vietnam Vets honored on June 25 ceremony | Kossuth County Advance</title>
    <link rel="stylesheet" media="all" href="/sites/default/files/css/css_valn8WVzrY_2thSoUgMTgbAChquLmUI1mfke5bxfJqI.css" />
<link rel="stylesheet" media="all" href="//fonts.googleapis.com/css?family=Roboto:400,500,700" />
<link rel="stylesheet" media="all" href="/sites/default/files/css/css_smTnRKpKzrE7WrQc0eu0DQeT-xI40W7IOrYugWminDU.css" />

    <script type="application/json" data-drupal-selector="drupal-settings-json">{"path":{"baseUrl":"\/","scriptPath":null,"pathPrefix":"","currentPath":"node\/27565","currentPathIsAdmin":false,"isFront":false,"currentLanguage":"en"},"pluralDelimiter":"\u0003","suppressDeprecationErrors":true,"simpleads":{"current_node_id":"27565"},"gavias_blockbuilder":{"url_edit":"\/admin\/structure\/gavias_blockbuilder\/edit\/-----"},"ajaxTrustedUrl":{"\/search\/node":true,"form_action_p_pvdeGsVG5zNF_XLGPTvYSKCf43t8qZYSwcfZl2uzM":true},"layzy_load":"on","gavias_load_ajax_view":"\/custom\/gavias_hook\/ajax_view","user":{"uid":0,"permissionsHash":"a362357f4877eafa231a6f1bd3b5a8494488e76ab729afbe95a92bd51bbbb524"}}</script>
<script src="/core/assets/vendor/jquery/jquery.min.js?v=3.6.0"></script>
<script src="/core/misc/drupalSettingsLoader.js?v=9.3.7"></script>
<script src="/core/misc/drupal.js?v=9.3.7"></script>
<script src="/core/misc/drupal.init.js?v=9.3.7"></script>
<script src="/themes/gavias_remito/vendor/jquery-migrate.min.js?v=9.3.7"></script>
<script src="/themes/gavias_remito/js/bootstrap.js?v=9.3.7"></script>
<script src="/themes/gavias_remito/js/imagesloader.min.js?v=9.3.7"></script>
<script src="/themes/gavias_remito/vendor/jquery.easing.js?v=9.3.7"></script>
<script src="/themes/gavias_remito/vendor/owl-carousel/owl.carousel.js?v=9.3.7"></script>
<script src="/themes/gavias_remito/vendor/perfect-scrollbar.jquery.min.js?v=9.3.7"></script>
<script src="/themes/gavias_remito/js/sidebar-sticky.js?v=9.3.7"></script>
<script src="/themes/gavias_remito/vendor/waypoint.js?v=9.3.7"></script>
<script src="/themes/gavias_remito/vendor/jquery.appear.js?v=9.3.7"></script>
<script src="/themes/gavias_remito/vendor/count-to.js?v=9.3.7"></script>
<script src="/themes/gavias_remito/vendor/masonry.pkgd.min.js?v=9.3.7"></script>
<script src="/themes/gavias_remito/vendor/isotope.pkgd.min.js?v=9.3.7"></script>
<script src="/themes/gavias_remito/vendor/jpreloader.min.js?v=9.3.7"></script>
<script src="/themes/gavias_remito/vendor/jquery.unveil.js?v=9.3.7"></script>
<script src="/themes/gavias_remito/vendor/magnific/jquery.magnific-popup.min.js?v=9.3.7"></script>
<script src="/themes/gavias_remito/vendor/popup-gallery/js/lightgallery.min.js?v=9.3.7"></script>
<script src="/themes/gavias_remito/vendor/jquery.hoverIntent.min.js?v=9.3.7"></script>
<script src="/themes/gavias_remito/vendor/wow.js?v=9.3.7"></script>
<script src="/themes/gavias_remito/js/main.js?v=9.3.7"></script>

    
    

    <link rel="stylesheet" href="https://www.algona.com/themes/gavias_remito/css/custom.css" media="screen" />
    <link rel="stylesheet" href="https://www.algona.com/themes/gavias_remito/css/update.css" media="screen" />
    
    

          <style class="customize"> </style>
    
          <style type="text/css">
        header.header-v1 .topbar {color: rgba(255, 255, 255, 0.6);background: #4b0c12;}.flagad {float: left;}.node--view-mode-teaser-3.node-index-1 .post-content {margin-top: 0px;}.owl-item .views-field-title {padding: 2px 8px; font-weight: bold;}.footer h2 {color: #fff;font-size: 16px;font-weight: 700;font-family: "Roboto", serif;text-transform: uppercase;letter-spacing: 0.5px;}.product--variation-field--variation_price__4 {font-size: 20px; display: block; max-width: 100%; width: 100%; float: none; clear: both; background: #f1f1f1; text-align: right; padding: 10px; }.js-form-item-terms {height: 700px;}.block-views-block-teaser-block-1 footer {text-align: center; font-weight: bold; font-style: italic;}.block-views-block-teaser-block-1 footer a {border-bottom: 1px dotted #303c4d; color: #303c4d; font-weight: bold;}.block-views-block-teaser-block-1 footer a:hover {color: #157efb;}#block-views-block-teaser-block-1 footer {text-align: center; font-weight: bold; font-style: italic;}#block-views-block-teaser-block-1 footer a {border-bottom: 1px dotted #303c4d; color: #303c4d; font-weight: bold;}#block-views-block-teaser-block-1 footer a:hover {color: #157efb;}.simpleads-reference-field img {width: 300px; height: auto;}.views-field-field-print-ad {height: 490px;}.views-field-field-print-ad img {max-height: 450px; width: auto;}
      </style>
      
<script type='text/javascript' src='https://platform-api.sharethis.com/js/sharethis.js#property=610acd76c952be0019351048&product=sop' async='async'></script>
  </head>
    <body class="layout-no-sidebars not-preloader boxed path-node node--type-article">
    <a href="#main-content" class="visually-hidden focusable">
      Skip to main content
    </a>
    
      <div class="dialog-off-canvas-main-canvas" data-off-canvas-main-canvas>
    <div class="body-page">
	       <header id="header" class="header-v1">
  
  <div class="topbar">
  <div class="container">
    <div class="row">
      
      <div class="topbar-left col-sm-6 col-xs-12 hidden-xs">
                    <div>
    <nav role="navigation" aria-labelledby="block-gavias-remito-useraccountmenu-menu" id="block-gavias-remito-useraccountmenu" class="block block-menu navigation menu--account">
          
  
  <h2  class="visually-hidden block-title" id="block-gavias-remito-useraccountmenu-menu"><span>User account menu</span></h2>
  
  <div class="block-content">
                 
              <ul class="gva_menu">
        
            <li  class="menu-item">
        <a href="/contact" gva_layout="menu-list" gva_layout_columns="3" gva_block="gavias_remito_afterfooter" data-drupal-link-system-path="contact">Contact</a>
        
      </li>
    
            <li  class="menu-item">
        <a href="/user/login" data-drupal-link-system-path="user/login">Log in</a>
        
      </li>
        </ul>
  


        </div>  
</nav>

  </div>

              </div>

      <div class="topbar-right col-sm-6 col-xs-12">
        <div class="social-list">
                      <a href="https://www.facebook.com/hallmarkintegratedmedia/"><i class="fa fa-facebook"></i></a>
           
           
           
           
           
           
           
           
           
            
                      <a href="/user/login"><i class="fa fa-user"></i></a>
            
        </div>  
      </div>
    </div>
  </div>  
</div>

   <div class="header-main">
      <div class="container">
         <div class="header-main-inner">
            <div class="row">
               <div class="col-lg-12 col-md-12 col-xs-12">
                                   <div>
    <div id="block-mainlogo" class="block block-block-content block-block-content8736452c-f367-450d-ba03-56fa51a9aa7b no-title">
  
    
      <div class="content block-content">
      
            <div class="field field--name-body field--type-text-with-summary field--label-hidden field__item"><div align="center"><a href="/home"><img alt="APC Logo Burgundy 0" data-entity-type="file" data-entity-uuid="6174b28f-d9f1-441d-b19b-304c46a62a64" height="auto" src="/sites/default/files/inline-images/APC%20Logo%20Burgundy_0.jpg" width="400" loading="lazy" class="align-center" /></a></div>
</div>
      
    </div>
  </div>

  </div>

                              </div>

               <div class="col-lg-4 col-md-4 col-xs-12 header-right">
                                       <div class="header-right-inner">
                          <div>
    <div id="block-advancelogo" class="block block-block-content block-block-content23b84415-bb5c-495f-b2b4-b28d99bd9d82 no-title">
  
    
      <div class="content block-content">
      
            <div class="field field--name-body field--type-text-with-summary field--label-hidden field__item"><a href="/home"><img alt="Advance Logo with Orange" data-entity-type="file" data-entity-uuid="e3de5968-91a8-4ccb-95d0-7d4c21e9ff9a" height="auto" src="/sites/default/files/inline-images/Advance%20Logo%20with%20Orange.jpg" width="300" loading="lazy" class="align-center" /></a></div>
      
    </div>
  </div>

  </div>

                     </div>
                                  </div>
               <div class="col-lg-4 col-md-4 col-xs-12 header-right">
                                       <div class="header-right-inner">
                          <div>
    <div id="block-makeitlogo" class="block block-block-content block-block-contentd665f377-fa41-4342-aa7b-32afc3ea810d no-title">
  
    
      <div class="content block-content">
      
            <div class="field field--name-body field--type-text-with-summary field--label-hidden field__item"><a href="https://www.makeitpersonalpromotionalproducts.com/"><img alt="Make It Personal FINAL logo COLOR copy" data-entity-type="file" data-entity-uuid="beae1473-1134-47ad-a36c-9aadbdc987b3" height="auto" src="/sites/default/files/inline-images/Make%20It%20Personal%20FINAL%20logo%20COLOR%20copy.png" width="160" loading="lazy" class="align-center" /></a></div>
      
    </div>
  </div>

  </div>

                     </div>
                                  </div>
               <div class="col-lg-4 col-md-4 col-xs-12 header-right">
                                       <div class="header-right-inner">
                          <div>
    <div id="block-reminderlogo" class="block block-block-content block-block-contentf56301cd-14a5-4960-be9b-38a492d6c133 no-title">
  
    
      <div class="content block-content">
      
            <div class="field field--name-body field--type-text-with-summary field--label-hidden field__item"><a href="/E-Ediition"><img alt="Reminder Flag for Websites" data-entity-type="file" data-entity-uuid="28fc01fa-3a43-4c73-9433-752941981fa9" height="auto" src="/sites/default/files/inline-images/Reminder%20Flag%20for%20Websites.jpg" width="300" loading="lazy" class="align-center" /></a></div>
      
    </div>
  </div>

  </div>

                     </div>
                                  </div>
            </div>
         </div>
      </div>
   </div>

    <div class="header-bottom ">
      <div class="main-menu">
        <div class="container">
           <div class="row">
              <div class="col-xs-12 area-main-menu">
                <div class="area-inner menu-hover">
                  
                  <div class="gva-offcanvas-inner">
                    <div class="close-offcanvas hidden-lg hidden-md"><a><i class="fa fa-times"></i></a></div>
                                            <div>
    <nav role="navigation" aria-labelledby="block-gavias-remito-main-menu-menu" id="block-gavias-remito-main-menu" class="block block-menu navigation menu--main">
          
  
  <h2  class="visually-hidden block-title" id="block-gavias-remito-main-menu-menu"><span>Main navigation</span></h2>
  
  <div class="block-content">
                 
<div class="gva-navigation">

              <ul class="clearfix gva_menu gva_menu_main">
                                      <li  class="menu-item ">
        <a href="/">
                    Home
            
        </a>
          
              </li>
                                  <li  class="menu-item ">
        <a href="/submissions">
                    Submissions
            
        </a>
          
              </li>
                                  <li  class="menu-item">
        <a href="/news">
                    News
            
        </a>
          
              </li>
                                  <li  class="menu-item">
        <a href="/obituaries">
                    Obituaries
            
        </a>
          
              </li>
                                  <li  class="menu-item">
        <a href="/sports">
                    Sports
            
        </a>
          
              </li>
                                  <li  class="menu-item ">
        <a href="/subscribe">
                    Subscribe
            
        </a>
          
              </li>
                                  <li  class="menu-item">
        <a href="/E-Ediition">
                    E-Editions
            
        </a>
          
              </li>
                                  <li  class="menu-item">
        <a href="/classifieds">
                    Classifieds
            
        </a>
          
              </li>
                                  <li  class="menu-item">
        <a href="/taxonomy/term/60">
                    Opinions
            
        </a>
          
              </li>
                                  <li  class="menu-item ">
        <a href="http://iapublicnotices.newzgroup.com/">
                    Public Notices
            
        </a>
          
              </li>
        </ul>
  

</div>

        </div>  
</nav>

  </div>

                      
                                      </div>
                  
                  <div id="menu-bar" class="menu-bar mobile hidden-lg hidden-md">
                    <span class="one"></span>
                    <span class="two"></span>
                    <span class="three"></span>
                  </div>

                                      <div class="menu-another hidden-xs hidden-sm">
                      <div id="menu-bar-another" class="menu-bar">
                        <span class="one"></span>
                        <span class="two"></span>
                        <span class="three"></span>
                      </div>
                      <div class="content-inner">
                          <div>
    <nav role="navigation" aria-labelledby="block-gavias-remito-menusecond-2-menu" id="block-gavias-remito-menusecond-2" class="block block-menu navigation menu--menu-second">
          
  
  <h2  class="visually-hidden block-title" id="block-gavias-remito-menusecond-2-menu"><span>Menu second</span></h2>
  
  <div class="block-content">
                 
<div class="gva-navigation">

              <ul class="gva_menu gva_menu_main">
                                      <li  class="menu-item">
        <a href="/birth-announcement">
                    Birth Announcements
            
        </a>
          
              </li>
                                  <li  class="menu-item">
        <a href="/engagement-announcement">
                    Engagement Announcements
            
        </a>
          
              </li>
                                  <li  class="menu-item">
        <a href="/wedding-announcement">
                    Wedding Announcements
            
        </a>
          
              </li>
                                  <li  class="menu-item">
        <a href="/letter-to-the-editor">
                    Letter to the Editor
            
        </a>
          
              </li>
                                  <li  class="menu-item">
        <a href="/news-tips">
                    News Tips
            
        </a>
          
              </li>
                                  <li  class="menu-item">
        <a href="/milestone">
                    Birthday/Anniversary Milestones
            
        </a>
          
              </li>
                                  <li  class="menu-item">
        <a href="/obitsubmission">
                    Obituary Submission
            
        </a>
          
              </li>
        </ul>
  

</div>

        </div>  
</nav>

  </div>

                      </div>
                    </div>  
                  
                                   
                </div>   
              </div>
           </div>
        </div>
      </div>
   </div>

         <div class="breaking-news">
        <div class="container clearfix">
          <div class="content-inner">  <div>
    <div class="views-element-container block block-views block-views-blockarticle-blocks-block-6 no-title" id="block-gavias-remito-views-block-article-blocks-block-6">
  
    
      <div class="content block-content">
      <div><div class="view-post-breaking-news js-view-dom-id-f1eb4ee3320c5f1623628c927da27efbc39110d182d3d0169c059768af73dbda">
  
  
  

  
  
  

  <div class="owl-carousel init-carousel-owl" data-items="4" data-items_lg="4" data-items_md="3" data-items_sm="2" data-items_xs="2" data-loop="1" data-speed="200" data-auto_play="1" data-auto_play_speed="5000" data-auto_play_timeout="6000" data-auto_play_hover="0" data-navigation="1" data-rewind_nav="0" data-pagination="0" data-mouse_drag="1" data-touch_drag="1">
   
   
             <div class="item">
            <div><div role="article" about="/news/fishing-derby-set-sunday-june-26-siems-park-near-whittemore" typeof="schema:Article" class="node node--type-article node--promoted node--view-mode-small clearfix small-post post-block">
  <div class="post-image"></div>
  <div class="post-content">    
      <div class="post-title"><a href="/news/fishing-derby-set-sunday-june-26-siems-park-near-whittemore">
<span property="schema:name">Fishing Derby set for Sunday, June 26 at Siems Park near Whittemore</span>
</a></div>
      <div class="post-meta">  <span class="post-categories red" ><a href="/news" hreflang="en">News</a></span>
<span class="post-created"> 16 June 2022</span> </div>
   </div>
</div>  
</div>
         </div>
             <div class="item">
            <div><div role="article" about="/news/limbaughs-mark-70-years-business-june-22-event" typeof="schema:Article" class="node node--type-article node--promoted node--view-mode-small clearfix small-post post-block">
  <div class="post-image">
            <div class="field field--name-field-image field--type-image field--label-hidden field__item">  <a href="/news/limbaughs-mark-70-years-business-june-22-event" hreflang="en"><img property="schema:image" src="" width="90" height="90" alt="Kossuth County Advance - Staff Photo - Create Article" loading="lazy" data-src="/sites/default/files/styles/thumbnail/public/articles/Jack%27s%20Tire%20photo.jpg?itok=eXVhFsqp" class="unveil-image" />

</a>
</div>
      </div>
  <div class="post-content">    
      <div class="post-title"><a href="/news/limbaughs-mark-70-years-business-june-22-event">
<span property="schema:name">Limbaughs mark 70 years in business with June 22 event</span>
</a></div>
      <div class="post-meta">  <span class="post-categories red" ><a href="/news" hreflang="en">News</a></span>
<span class="post-created"> 15 June 2022</span> </div>
   </div>
</div>  
</div>
         </div>
             <div class="item">
            <div><div role="article" about="/news/kemna-flys-athletes-special-olympics" typeof="schema:Article" class="node node--type-article node--promoted node--view-mode-small clearfix small-post post-block">
  <div class="post-image">
            <div class="field field--name-field-image field--type-image field--label-hidden field__item">  <a href="/news/kemna-flys-athletes-special-olympics" hreflang="en"><img property="schema:image" src="" width="90" height="90" alt="Kossuth County Advance - Staff Photo - Create Article" loading="lazy" data-src="/sites/default/files/styles/thumbnail/public/articles/IMG954928.jpg?itok=of_f9spb" class="unveil-image" />

</a>
</div>
      </div>
  <div class="post-content">    
      <div class="post-title"><a href="/news/kemna-flys-athletes-special-olympics">
<span property="schema:name">Kemna flys athletes to Special Olympics</span>
</a></div>
      <div class="post-meta">  <span class="post-categories red" ><a href="/news" hreflang="en">News</a></span>
<span class="post-created"> 15 June 2022</span> </div>
   </div>
</div>  
</div>
         </div>
             <div class="item">
            <div><div role="article" about="/news/baseball-traditions-continue-bancroft" typeof="schema:Article" class="node node--type-article node--promoted node--view-mode-small clearfix small-post post-block">
  <div class="post-image">
            <div class="field field--name-field-image field--type-image field--label-hidden field__item">  <a href="/news/baseball-traditions-continue-bancroft" hreflang="en"><img property="schema:image" src="" width="90" height="90" alt="Kossuth County Advance - Staff Photo - Create Article" loading="lazy" data-src="/sites/default/files/styles/thumbnail/public/articles/Team%20Photo.jpg?itok=W8dN5I8V" class="unveil-image" />

</a>
</div>
      </div>
  <div class="post-content">    
      <div class="post-title"><a href="/news/baseball-traditions-continue-bancroft">
<span property="schema:name">Baseball traditions continue in Bancroft</span>
</a></div>
      <div class="post-meta">  <span class="post-categories red" ><a href="/news" hreflang="en">News</a></span>
<span class="post-created"> 15 June 2022</span> </div>
   </div>
</div>  
</div>
         </div>
             <div class="item">
            <div><div role="article" about="/news/alumni-golf-outing-raises-5700-youth-rec-programs" typeof="schema:Article" class="node node--type-article node--promoted node--view-mode-small clearfix small-post post-block">
  <div class="post-image">
            <div class="field field--name-field-image field--type-image field--label-hidden field__item">  <a href="/news/alumni-golf-outing-raises-5700-youth-rec-programs" hreflang="en"><img property="schema:image" src="" width="90" height="90" alt="Kossuth County Advance - Staff Photo - Create Article" loading="lazy" data-src="/sites/default/files/styles/thumbnail/public/articles/Golf%20winners%202022%20women.jpg?itok=WR7SnOn9" class="unveil-image" />

</a>
</div>
      </div>
  <div class="post-content">    
      <div class="post-title"><a href="/news/alumni-golf-outing-raises-5700-youth-rec-programs">
<span property="schema:name">Alumni golf outing raises $5,700 for youth rec programs</span>
</a></div>
      <div class="post-meta">  <span class="post-categories red" ><a href="/news" hreflang="en">News</a></span>
<span class="post-created"> 15 June 2022</span> </div>
   </div>
</div>  
</div>
         </div>
             <div class="item">
            <div><div role="article" about="/news/vietnam-vets-honored-june-25-ceremony" typeof="schema:Article" class="node node--type-article node--promoted node--view-mode-small clearfix small-post post-block">
  <div class="post-image">
            <div class="field field--name-field-image field--type-image field--label-hidden field__item">  <a href="/news/vietnam-vets-honored-june-25-ceremony" hreflang="en"><img property="schema:image" src="" width="90" height="90" alt="Kossuth County Advance - Staff Photo - Create Article" loading="lazy" data-src="/sites/default/files/styles/thumbnail/public/articles/image003.png?itok=XiMztAk-" class="unveil-image" />

</a>
</div>
      </div>
  <div class="post-content">    
      <div class="post-title"><a href="/news/vietnam-vets-honored-june-25-ceremony">
<span property="schema:name">Vietnam Vets honored on June 25 ceremony</span>
</a></div>
      <div class="post-meta">  <span class="post-categories red" ><a href="/news" hreflang="en">News</a></span>
<span class="post-created"> 15 June 2022</span> </div>
   </div>
</div>  
</div>
         </div>
             <div class="item">
            <div><div role="article" about="/news/three-students-awarded-1000-kiwanis" typeof="schema:Article" class="node node--type-article node--promoted node--view-mode-small clearfix small-post post-block">
  <div class="post-image">
            <div class="field field--name-field-image field--type-image field--label-hidden field__item">  <a href="/news/three-students-awarded-1000-kiwanis" hreflang="en"><img property="schema:image" src="" width="90" height="90" alt="Kossuth County Advance - Staff Photo - Create Article" loading="lazy" data-src="/sites/default/files/styles/thumbnail/public/articles/20220609_123607_resized_1.jpg?itok=q3yQ8qxO" class="unveil-image" />

</a>
</div>
      </div>
  <div class="post-content">    
      <div class="post-title"><a href="/news/three-students-awarded-1000-kiwanis">
<span property="schema:name">Three students awarded $1,000 from Kiwanis</span>
</a></div>
      <div class="post-meta">  <span class="post-categories red" ><a href="/news" hreflang="en">News</a></span>
<span class="post-created"> 15 June 2022</span> </div>
   </div>
</div>  
</div>
         </div>
             <div class="item">
            <div><div role="article" about="/news/offerman-awarded-scholarship" typeof="schema:Article" class="node node--type-article node--promoted node--view-mode-small clearfix small-post post-block">
  <div class="post-image">
            <div class="field field--name-field-image field--type-image field--label-hidden field__item">  <a href="/news/offerman-awarded-scholarship" hreflang="en"><img property="schema:image" src="" width="90" height="90" alt="Kossuth County Advance - Staff Photo - Create Article" loading="lazy" data-src="/sites/default/files/styles/thumbnail/public/articles/Offerman.jpg?itok=7Ub5j3hX" class="unveil-image" />

</a>
</div>
      </div>
  <div class="post-content">    
      <div class="post-title"><a href="/news/offerman-awarded-scholarship">
<span property="schema:name">Offerman awarded scholarship</span>
</a></div>
      <div class="post-meta">  <span class="post-categories red" ><a href="/news" hreflang="en">News</a></span>
<span class="post-created"> 15 June 2022</span> </div>
   </div>
</div>  
</div>
         </div>
    
</div>

    

  
  

  
  
</div>
</div>

    </div>
  </div>

  </div>
</div> 
        </div> 
      </div>
    </header>
	
    

  <div class="help show">
    <div class="container">
      <div class="content-inner">
          <div>
    <div data-drupal-messages-fallback class="hidden"></div>

  </div>

      </div>
    </div>
  </div>

<div class="clearfix"></div>

  <div class="before_content area">
    <div class="container">
      <div class="row">
        <div class="col-xs-12">
            <div>
    <div id="block-simpleads-14" class="block-simpleads block no-title">
  
    
      <div class="content block-content">
      <div class="simpleads" data-group="17" data-ref-node="0" data-ref-simpleads="0" data-rotation-type="refresh" data-impressions="true"></div>

    </div>
  </div>

  </div>

          </div>
      </div>
    </div>
  </div>

<div class="clearfix"></div>

	<div role="main" class="main main-page">	
		<div id="content" class="content content-full">
			<div class="container">	
				
<div class="content-main-inner">
	<div class="row">
		
					
						 				 		
							
       

		<div id="page-main-content" class="main-content col-xs-12 col-md-8 sb-r ">
						  <div class="breadcrumbs">
			      <div>
    
<div class="breadcrumb-content-inner">
  <div id="block-gavias-remito-breadcrumbs" class="text-dark block gva-block-breadcrumb block-system block-system-breadcrumb-block no-title">
    <div class="breadcrumb-style" style="background-color: #FFF;background-position: center top;background-repeat: no-repeat;">
      <div class="clearfix">
        <div class="content-inner">
          <h2 class="page-title hidden"> </h2>
           
                      
                      <div class="">
              <div class="content block-content">
                  <nav class="breadcrumb" role="navigation">
    <h2 id="system-breadcrumb" class="visually-hidden">Breadcrumb</h2>
    <ol>
      
                <li>
                  <a href="/">Home</a>
                          <span>&nbsp;/&nbsp;</span>
          
      </li>
                <li>
                  <a href="/news">News</a>
                          <span>&nbsp;/&nbsp;</span>
          
      </li>
                <li>
                  <a href="/news">News</a>
                          <span>&nbsp;/&nbsp;</span>
          
      </li>
                <li>
                  
                  
      </li>
                <li>
                  Vietnam Vets honored on June 25 ceremony
                  
      </li>
        </ol>
  </nav>

              </div>
            </div>  
                  </div>  
      </div>
    </div>
  </div>     
</div>

  </div>
  
			  </div>
						<div class="main-content-inner">
				
				
									<div class="content-main">
						  <div>
    <div id="block-gavias-remito-content" class="block block-system block-system-main-block no-title">
  
    
      <div class="content block-content">
      

  <div role="article" about="/news/vietnam-vets-honored-june-25-ceremony" typeof="schema:Article" class="node node--type-article node--promoted node--view-mode-teaser clearfix post-block node-index-1">
    <div class="post-thumbnail">
      <a href="/news/vietnam-vets-honored-june-25-ceremony">
            <div class="field field--name-field-image field--type-image field--label-hidden field__item">  <a href="/news/vietnam-vets-honored-june-25-ceremony" hreflang="en"><img property="schema:image" src="" width="780" height="535" alt="Kossuth County Advance - Staff Photo - Create Article" loading="lazy" data-src="/sites/default/files/styles/medium/public/articles/image003.png?itok=eAUIkSrK" class="unveil-image" />

</a>
</div>
      </a>
      <div class="icons-format">
                      </div>
    </div>
    <div class="post-content">
      <div class="post-meta">  <span class="post-categories red" ><a href="/news" hreflang="en">News</a></span>
<span class="post-created"> 15 June 2022</span></div>
      <h3 class="post-title"><a href="/news/vietnam-vets-honored-june-25-ceremony" rel="bookmark">
<span property="schema:name">Vietnam Vets honored on June 25 ceremony</span>
</a></h3>
      <div class="post-body">
            <div property="schema:text" class="field field--name-body field--type-text-with-summary field--label-hidden field__item"><p> </p>

<p>SWEA CITY—The Anna Maria Lane and Algona Chapters of the National Society of the Daughters of the American Revolution have announced the keynote speaker will be Lt. Col Tres Smith at the upcoming Vietnam Veterans Day Commemoration event to be held at the Swea City Fun Days on Saturday, June 25 at 1 p.m. at the city park.</p></div>
      </div>
    </div>
  </div>  

    </div>
  </div>
<div class="views-element-container block block-views block-views-blockpremium-content1-block-1 no-title" id="block-views-block-premium-content1-block-1">
  
    
      <div class="content block-content">
      <div><div class="js-view-dom-id-6cb1f217b4210fae3a261ae4855dd954d46cd4c54d7d438e9cd71191b5ebd403">
  
  
  

  
  
  

  <div class="view-content-wrap " data-items="">
             <div class="item">
       <div class="views-field views-field-nothing"><span class="field-content">---
<strong>Online Subscribers:</strong> Please <u><a href="/user/login">click here to log in</a></u> to read this story and access algona.com.<br /><br />
<strong>Not an Online Subscriber?</strong> <u><a href="/subscribe">Click here to subscribe</a></u>.
<br /><br /><br /><br /></span></div>
     </div>
   </div>
    

  
  

  
  
</div>
</div>

    </div>
  </div>
<div id="block-simpleads-16" class="block-simpleads block no-title">
  
    
      <div class="content block-content">
      <div class="simpleads" data-group="18" data-ref-node="0" data-ref-simpleads="0" data-rotation-type="refresh" data-impressions="true"></div>

    </div>
  </div>
<div id="block-anonymoussubscription" class="block block-anonymous-subscriptions block-subscribe-block">
  
      <h2 class="block-title" ><span>Sign up for News Alerts</span></h2>
    
      <div class="content block-content">
      <form class="anonymous-subscriptions-subscribe-form" data-drupal-selector="anonymous-subscriptions-subscribe-form" action="/news/vietnam-vets-honored-june-25-ceremony" method="post" id="anonymous-subscriptions-subscribe-form" accept-charset="UTF-8">
  <p>Subscribe to news updates</p><div class="js-form-item form-item js-form-type-email form-item-email js-form-item-email">
      <label for="edit-email" class="js-form-required form-required">Your email</label>
        <input data-drupal-selector="edit-email" type="email" id="edit-email" name="email" value="" size="60" maxlength="254" class="form-email required" required="required" aria-required="true" />

        </div>
<input data-drupal-selector="edit-submit" type="submit" id="edit-submit" name="op" value="Subscribe" class="button js-form-submit form-submit" />
<input data-drupal-selector="edit-type" type="hidden" name="type" value="article" />
<input autocomplete="off" data-drupal-selector="form-fgfrtf5ab40r6qeoraecmzy1rlwx4xftfzhjsvguwp0" type="hidden" name="form_build_id" value="form-fgfRTF5Ab40R6qeoRAECMzy1rLWx4xFtfZHJSvguwp0" />
<input data-drupal-selector="edit-anonymous-subscriptions-subscribe-form" type="hidden" name="form_id" value="anonymous_subscriptions_subscribe_form" />

</form>

    </div>
  </div>

  </div>

					</div>
				
							</div>

		</div>

		<!-- Sidebar Left -->
				<!-- End Sidebar Left -->

		<!-- Sidebar Right -->
					
							 

			<div class="col-lg-4 col-md-4 col-sm-12 col-xs-12 sidebar sidebar-right theiaStickySidebar">
				<div class="sidebar-inner">
					  <div>
    <div class="search-block-form block block-search container-inline" data-drupal-selector="search-block-form" id="block-gavias-remito-search" role="search">
  
    
      <form action="/search/node" method="get" id="search-block-form" accept-charset="UTF-8" class="search-form search-block-form">
  <div class="js-form-item form-item js-form-type-search form-item-keys js-form-item-keys form-no-label">
      <label for="edit-keys" class="visually-hidden">Search</label>
        <input title="Enter the terms you wish to search for." data-drupal-selector="edit-keys" type="search" id="edit-keys" name="keys" value="" size="15" maxlength="128" class="form-search" />

        </div>
<div data-drupal-selector="edit-actions" class="form-actions js-form-wrapper form-wrapper" id="edit-actions"><input class="search-form__submit button js-form-submit form-submit" data-drupal-selector="edit-submit" type="submit" id="edit-submit" value="Search" />
</div>

</form>

  </div>
<div id="block-simpleads" class="block-simpleads block no-title">
  
    
      <div class="content block-content">
      <div class="simpleads" data-group="2" data-ref-node="0" data-ref-simpleads="0" data-rotation-type="refresh" data-impressions="true"></div>

    </div>
  </div>
<div id="block-simpleads-2" class="block-simpleads block no-title">
  
    
      <div class="content block-content">
      <div class="simpleads" data-group="6" data-ref-node="0" data-ref-simpleads="0" data-rotation-type="refresh" data-impressions="true"></div>

    </div>
  </div>
<div id="block-simpleads-3" class="block-simpleads block no-title">
  
    
      <div class="content block-content">
      <div class="simpleads" data-group="7" data-ref-node="0" data-ref-simpleads="0" data-rotation-type="refresh" data-impressions="true"></div>

    </div>
  </div>
<div id="block-simpleads-4" class="block-simpleads block no-title">
  
    
      <div class="content block-content">
      <div class="simpleads" data-group="8" data-ref-node="0" data-ref-simpleads="0" data-rotation-type="refresh" data-impressions="true"></div>

    </div>
  </div>
<div class="poll-view block block-poll block-poll-recent-block" id="block-mostrecentpoll">
  
      <h2 class="block-title" ><span>Did you vote in the primary election?</span></h2>
    
      <div class="content block-content">
      <div><form class="approval-poll-view-form-21 approval-poll-view-form poll-view-form poll-view-form-21" data-drupal-selector="approval-poll-view-form-21" action="/news/vietnam-vets-honored-june-25-ceremony" method="post" id="approval-poll-view-form-21" accept-charset="UTF-8">
  <div class="poll">
      <h3 class="poll-results-title">Results</h3>
    <dl>
    <dt class="choice-title not-current-selection">Yes</dt>
<dd class="choice-result not-current-selection">
  <div class="bar" data-max="1" data-min="0" data-choice="Yes" data-value="1">
    <div style="width: 100%" class="foreground"></div>
  </div>

      <div class="percent">100% (1 vote)</div>
  </dd>
<dt class="choice-title not-current-selection">No</dt>
<dd class="choice-result not-current-selection">
  <div class="bar" data-max="1" data-min="0" data-choice="No" data-value="0">
    <div style="width: 0%" class="foreground"></div>
  </div>

      <div class="percent">0% (0 votes)</div>
  </dd>
<dt class="choice-title not-current-selection">I forgot</dt>
<dd class="choice-result not-current-selection">
  <div class="bar" data-max="1" data-min="0" data-choice="I forgot" data-value="0">
    <div style="width: 0%" class="foreground"></div>
  </div>

      <div class="percent">0% (0 votes)</div>
  </dd>

  </dl>
  <div class="total">
    Total votes: 1  </div>
</div>
<input autocomplete="off" data-drupal-selector="form-dajjj6awqu080x2p09c1nfak8nnkdqfu9vtfytp8fjq" type="hidden" name="form_build_id" value="form-dajJJ6AWQU080X2P09C1nFak8nnkdQFU9VTFytP8fJQ" />
<input data-drupal-selector="edit-approval-poll-view-form-21" type="hidden" name="form_id" value="approval_poll_view_form_21" />

</form>
</div>

    </div>
  </div>
<div id="block-simpleads-6" class="block-simpleads block no-title">
  
    
      <div class="content block-content">
      <div class="simpleads" data-group="9" data-ref-node="0" data-ref-simpleads="0" data-rotation-type="refresh" data-impressions="true"></div>

    </div>
  </div>
<div id="block-simpleads-7" class="block-simpleads block no-title">
  
    
      <div class="content block-content">
      <div class="simpleads" data-group="10" data-ref-node="0" data-ref-simpleads="0" data-rotation-type="refresh" data-impressions="true"></div>

    </div>
  </div>
<div id="block-simpleads-10" class="block-simpleads block no-title">
  
    
      <div class="content block-content">
      <div class="simpleads" data-group="11" data-ref-node="0" data-ref-simpleads="0" data-rotation-type="refresh" data-impressions="true"></div>

    </div>
  </div>
<div id="block-simpleads-8" class="block-simpleads block no-title">
  
    
      <div class="content block-content">
      <div class="simpleads" data-group="12" data-ref-node="0" data-ref-simpleads="0" data-rotation-type="refresh" data-impressions="true"></div>

    </div>
  </div>
<div id="block-simpleads-9" class="block-simpleads block no-title">
  
    
      <div class="content block-content">
      <div class="simpleads" data-group="13" data-ref-node="0" data-ref-simpleads="0" data-rotation-type="refresh" data-impressions="true"></div>

    </div>
  </div>
<div class="views-element-container block block-views block-views-blockcategories-post-block-2" id="block-gavias-remito-views-block-categories-post-block-2">
  
      <h2 class="block-title" ><span>Tags </span></h2>
    
      <div class="content block-content">
      <div><div class="tags-list js-view-dom-id-439ebba614169bcc91d4c41db94e312b0503684c8a6f858ad7cc9f6f9f493bf3">
  
  
  

  
  
  

  <div class="item-list">
    <ul>
          <li class="view-list-item" ><div class="views-field views-field-name"><span class="field-content"><a href="/news" hreflang="en">News</a></span></div></li>
          <li class="view-list-item" ><div class="views-field views-field-name"><span class="field-content"><a href="/sports" hreflang="en">Sports</a></span></div></li>
          <li class="view-list-item" ><div class="views-field views-field-name"><span class="field-content"><a href="/legals" hreflang="en">Legal Notices</a></span></div></li>
          <li class="view-list-item" ><div class="views-field views-field-name"><span class="field-content"><a href="/obituaries" hreflang="en">Obituaries</a></span></div></li>
          <li class="view-list-item" ><div class="views-field views-field-name"><span class="field-content"><a href="/taxonomy/term/60" hreflang="en">Opinions</a></span></div></li>
      </ul>
</div>

    

  
  

  
  
</div>
</div>

    </div>
  </div>
<div id="block-simpleads-11" class="block-simpleads block no-title">
  
    
      <div class="content block-content">
      <div class="simpleads" data-group="14" data-ref-node="0" data-ref-simpleads="0" data-rotation-type="refresh" data-impressions="true"></div>

    </div>
  </div>

  </div>

				</div>
			</div>
				<!-- End Sidebar Right -->
		
	</div>
</div>


			</div>
		</div>			
	</div>

	

	 
	  
<footer id="footer" class="footer">
  <div class="footer-inner">
    
         
     <div class="footer-center">
        <div class="container">      
           <div class="row">
                              <div class="footer-first col-lg-6 col-md-6 col-sm-12 col-xs-12 column">
                    <div>
    <div id="block-gavias-remito-contactinfo" class="block block-block-content block-block-content7da38301-272f-4979-8de1-06b564010f17">
  
      <h2 class="block-title" ><span>Kossuth County Advance</span></h2>
    
      <div class="content block-content">
      
            <div class="field field--name-body field--type-text-with-summary field--label-hidden field__item"><div class="contact-info">
    <span class="description"> </span>
	<ul class="contact-info">
		<li><span><i class="fa fa-home"></i> 14 E. Nebraska St., Algona, IA 50511  </span> </li>
		<li><span><i class="fa fa-mobile-phone"></i>  (515) 295-3535</span></li>
<li><span><i class="fa fa-fax"></i>  (515) 295-7217</span></li>
		<li><a href="mailto:news@algona.com"><i class="fa fa-envelope-o"></i> news@algona.com</a> </li>
		<li><a href="mailto:ads@algona.com"><i class="fa fa-envelope-o"></i> ads@algona.com</a> </li>
		<li><a href="mailto:circulation@algona.com"><i class="fa fa-envelope-o"></i> circulation@algona.com</a> </li>
		<li><a href="mailto:bookkeeper@algona.com"><i class="fa fa-envelope-o"></i> bookkeeper@algona.com</a> </li>
<li><a href="mailto:publisher@algona.com"><i class="fa fa-envelope-o"></i> publisher@algona.com</a> </li>
	</ul>
</div></div>
      
    </div>
  </div>

  </div>

                </div> 
              
                             <div class="footer-second col-lg-6 col-md-6 col-sm-12 col-xs-12 column">
                    <div>
    <nav role="navigation" aria-labelledby="block-menusecond-menu" id="block-menusecond" class="block block-menu navigation menu--menu-second">
    
  
  <h2  id="block-menusecond-menu"><span>Submissions</span></h2>
  
  <div class="block-content">
                 
<div class="gva-navigation">

              <ul class="gva_menu gva_menu_main">
                                      <li  class="menu-item">
        <a href="/birth-announcement">
                    Birth Announcements
            
        </a>
          
              </li>
                                  <li  class="menu-item">
        <a href="/engagement-announcement">
                    Engagement Announcements
            
        </a>
          
              </li>
                                  <li  class="menu-item">
        <a href="/wedding-announcement">
                    Wedding Announcements
            
        </a>
          
              </li>
                                  <li  class="menu-item">
        <a href="/letter-to-the-editor">
                    Letter to the Editor
            
        </a>
          
              </li>
                                  <li  class="menu-item">
        <a href="/news-tips">
                    News Tips
            
        </a>
          
              </li>
                                  <li  class="menu-item">
        <a href="/milestone">
                    Birthday/Anniversary Milestones
            
        </a>
          
              </li>
                                  <li  class="menu-item">
        <a href="/obitsubmission">
                    Obituary Submission
            
        </a>
          
              </li>
        </ul>
  

</div>

        </div>  
</nav>

  </div>

                </div> 
              
              
                         </div>   
        </div>
    </div>  

          <div class="footer-bottom">
        <div class="container">
          <div class="row">
            <div class="col-xs-12">
              <div class="after-footer clearfix area">
                    <div>
    <div id="block-farewayscript" class="block block-block-content block-block-content9543a59a-8cfb-4c0e-9368-439c9f331545 no-title">
  
    
      <div class="content block-content">
      
            <div class="field field--name-body field--type-text-with-summary field--label-hidden field__item"><div align="center"><!--Begin ClixTrac.com Banner Code -->
<p><a href="http://www.clixtrac.com/banner/click.php?banner=246527" target="_blank"><img alt="" border="0" src="https://www.clixtrac.com/banner/246527.jpg" title="" /></a> <!--End ClixTrac.com Banner Code --></p>

</div></div>
      
    </div>
  </div>
<div id="block-scriptad2" class="block block-block-content block-block-content163ef723-f822-4831-8bc5-8cc5aa2e8155 no-title">
  
    
      <div class="content block-content">
      
            <div class="field field--name-body field--type-text-with-summary field--label-hidden field__item">
<div align="center"> <!--Begin ClixTrac.com HTML Code -->
<a href="https://clixtrac.com/goto/?291007" target="_blank">
<img src="https://clixtrac.com/banner/291007.jpg" alt="" title="" border="0" /></a>
<!--End ClixTrac.com HTML Code --></div></div>
      
    </div>
  </div>

  </div>

              </div>
            </div>
          </div>     
        </div>   
      </div> 
    
  </div>   

      <div class="copyright">
      <div class="container">
        <div class="copyright-inner">
              <div>
    <div id="block-gavias-remito-copyright" class="block block-block-content block-block-content61f17841-749f-436d-9799-1dfeefd7ad43 no-title">
  
    
      <div class="content block-content">
      
            <div class="field field--name-body field--type-text-with-summary field--label-hidden field__item"><div class="text-center">© Copyright Algona Publishing 2021. All Rights Reserved.<br /><a href="https://surfnewmedia.com"><img src="https://surfnewmedia.com/webprint.png" /></a></div>
</div>
      
    </div>
  </div>

  </div>

        </div>   
      </div>   
    </div>
   
</footer>


	
</div>


  </div>

    
    <script src="/core/assets/vendor/js-cookie/js.cookie.min.js?v=3.0.1"></script>
<script src="/core/misc/jquery.cookie.shim.js?v=9.3.7"></script>
<script src="/modules/SimpleAds-8.x-1.11/js/simpleads.lib.js?v=9.3.7"></script>
<script src="/modules/SimpleAds-8.x-1.11/js/slick/slick.min.js?v=9.3.7"></script>
<script src="/modules/SimpleAds-8.x-1.11/js/modal/jquery.modal.min.js?v=9.3.7"></script>
<script src="/modules/SimpleAds-8.x-1.11/js/simpleads.block.js?v=9.3.7"></script>
<script src="/modules/gva_blockbuilder/vendor/skrollr.min.js?v=1.x"></script>
<script src="/modules/gva_blockbuilder/vendor/main.js?v=1.x"></script>

      </body>
</html>
